Users reporting error screens when navigating to various pages
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted about 1 month ago. May 17, 2017 - 15:42 MDT
Update
Site functionality is in the process of being restored.
Posted about 1 month ago. May 17, 2017 - 15:17 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. May 17, 2017 - 15:13 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. May 17, 2017 - 15:13 MDT
Investigating
We are currently investigating this issue.
Posted about 1 month ago. May 17, 2017 - 15:04 MDT