Intermittent problems connecting to Revolution Office
Incident Report for SendOutCards
Resolved
Although our service provider for Revolution Office has not confirmed any changes, this problem appears to be resolved. There have been no additional reports since Sunday morning.

We will close this incident but if you do have any additional problems please report it to support.

Thank you!
Posted 9 months ago. Oct 24, 2016 - 09:54 MDT
Investigating
There have been reports of problems connecting to Revolution Office. We have notified the service provider and are waiting for a response.

Most users who have seen this problem have been able to connect simply by waiting a minute and then trying to connect again. If you have this problem, please give that a try.

We will update this incident report as soon as we have more information.
Posted 9 months ago. Oct 23, 2016 - 08:03 MDT