Support phone system connectivity issues
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 17, 2017 - 17:14 MDT
Monitoring
Phone system connectivity has been restored.
Posted about 1 month ago. Oct 17, 2017 - 16:11 MDT
Investigating
Users are reporting connectivity issues when attempting to contact the SendOutCards Support Center via telephone @ 801-463-3800. Please direct any urgent support inquiries to support@sendoutcards.com while we resolve the connectivity issues. Thank you for your patience.
Posted about 1 month ago. Oct 17, 2017 - 15:51 MDT