Photo Uploading Issues
Incident Report for SendOutCards
Resolved
We have corrected and tested the fix for the photo uploading issue reported earlier today. This has been resolved.
Posted Feb 20, 2020 - 18:03 MST
Identified
We are aware that users are experiencing issues when uploading new photos. While the upload looks broken, it is working but there is a delay in the system updating. If you upload a photo, there may be a white screen that displays while your photo uploads. After your photo is uploaded, it may not immediately show in your My Images gallery. Our team is working on correcting this issue.
Posted Feb 20, 2020 - 12:19 MST
This incident affected: SendOutCards Website.