Internet connectivity outage at home office
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 15, 2018 - 09:09 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Jun 15, 2018 - 08:37 MDT
Investigating
The SendOutCards Corporate Office is currently experiencing internet connectivity issues. This outage is affecting phone access to our Customer Support Center. We are diligently working to fix the issue as soon as possible. We apologize for any inconvenience this has caused.
Posted about 1 month ago. Jun 15, 2018 - 07:41 MDT
This incident affected: SendOutCards Website.