Site Navigation Problems
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted 9 months ago. Nov 08, 2016 - 08:26 MST
Monitoring
We have identified and resolved the navigation problems.

If you are still seeing navigation problems, please clear your cache & cookies from the browser.
Posted 9 months ago. Nov 04, 2016 - 14:26 MDT
Investigating
Currently there are reports of the navigation being replaced with a jumble of symbols. Typically a refresh or two will return the normal navigation. We are working diligently to find and correct the problem.

Please try clearing your browsers CACHE & COOKIES.
Posted 9 months ago. Nov 04, 2016 - 14:04 MDT