Support phone system connectivity issues
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted about 1 month ago. Oct 16, 2017 - 13:04 MDT
Monitoring
Connectivity has been restored.
Posted about 1 month ago. Oct 16, 2017 - 13:03 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Oct 16, 2017 - 13:02 MDT
Investigating
Users are reporting connectivity issues when attempting to contact the SendOutCards Support Center via telephone @ 801-463-3800. Please direct any urgent support inquiries to support@sendoutcards.com while we resolve the connectivity issues. Thank you for your patience.
Posted about 1 month ago. Oct 16, 2017 - 13:01 MDT