Intermittent site problems
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted 10 months ago. Sep 23, 2016 - 19:12 MDT
Monitoring
Looks like we got this resolved, there were some network connectivity issues. We will monitor for another hour to be sure everything is working correctly.
Posted 10 months ago. Sep 23, 2016 - 16:30 MDT
Investigating
The website is experiencing unexpected problems currently. We are reviewing and will update as information becomes available.
Posted 10 months ago. Sep 23, 2016 - 16:10 MDT