Multiple reported site errors
Incident Report for SendOutCards
Identified
The issue has been identified and a fix is being implemented.
Posted 15 days ago. Apr 09, 2018 - 13:39 MDT
Investigating
The website is experiencing unexpected connectivity issues. Users are reporting error messages across multiple sections of the site. We are reviewing and will update as information becomes available. Thank you for your patience while our team addresses these issues!
Posted 15 days ago. Apr 09, 2018 - 10:00 MDT