Site outage
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 06, 2017 - 19:14 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Jun 06, 2017 - 19:12 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted 2 months ago. Jun 06, 2017 - 19:10 MDT
Investigating
The website is experiencing unexpected problems. We are reviewing and will update as information becomes available.
Posted 2 months ago. Jun 06, 2017 - 18:49 MDT