Full site outage
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 18, 2017 - 07:43 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted 4 months ago. Apr 18, 2017 - 07:24 MDT
Investigating
We are currently investigating this issue.
Posted 4 months ago. Apr 18, 2017 - 07:17 MDT