Sendcere.com Login Issues
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted 29 days ago. Mar 27, 2017 - 13:35 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 29 days ago. Mar 27, 2017 - 13:29 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted 29 days ago. Mar 27, 2017 - 13:28 MDT
Investigating
Users are currently not able to log into www.sendcere.com. The issue is currently being investigated.
Posted 29 days ago. Mar 27, 2017 - 09:38 MDT