Quick Support is currently off-line. The problem has been identified and is being worked on.
Incident Report for SendOutCards
Resolved
This issue has now been resolved. Thank you for your patience while waiting for this to be fixed. If you see any further issues please contact support.
Posted 11 months ago. Aug 26, 2016 - 07:48 MDT
Update
Temporarily, to get to the downloads page in the Quick Support you can use this link: https://sendoutcards.helpjuice.com/is-there-a-single-page-with-all-the-downloads-available
Posted 11 months ago. Aug 25, 2016 - 19:05 MDT
Identified
This problem means that there is no access to online support questions as well as company "downloads". We will update this when it is resolved. Please contact support or use chat during normal business hours if you have any questions.
Posted 11 months ago. Aug 25, 2016 - 19:01 MDT