Login not working correctly
Incident Report for SendOutCards
Resolved
The problem has been identified and resolved. Some unexpected server problems introduced the problem. These have been corrected. Thank you for your patience.
Posted about 1 year ago. May 29, 2016 - 22:21 MDT
Investigating
We have been notified that people are having trouble logging into the website and also the mobile apps. We are working on this and will resolve it as soon as possible.
Posted about 1 year ago. May 29, 2016 - 21:50 MDT