Site outage
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted 8 months ago. Sep 23, 2016 - 10:15 MDT
Monitoring
The problem has been resolved. We are monitoring to ensure the problem is resolved.
Posted 8 months ago. Sep 23, 2016 - 08:43 MDT
Investigating
The website is experiencing unexpected problems. We are reviewing and will update as information becomes available.
Posted 8 months ago. Sep 23, 2016 - 08:41 MDT