The website is experiencing unexpected problems.
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted 5 months ago. May 24, 2017 - 15:00 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. May 24, 2017 - 14:55 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted 5 months ago. May 24, 2017 - 14:22 MDT
Update
The website is experiencing unexpected problems. We are reviewing and will update as information becomes available.
Posted 5 months ago. May 24, 2017 - 14:04 MDT
Investigating
We are currently investigating this issue.
Posted 5 months ago. May 24, 2017 - 14:03 MDT