Third-party integration issues
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted 9 days ago. Jul 10, 2019 - 19:43 MDT
Update
We are continuing to investigate this issue.
Posted 9 days ago. Jul 10, 2019 - 16:31 MDT
Investigating
We are currently experience issues with our payment processor.
Posted 9 days ago. Jul 10, 2019 - 16:30 MDT
This incident affected: SendOutCards Website and Interfaces to Mobile Apps.