Support Phone system is currently experiencing connectivity issues
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted about 2 months ago. Aug 10, 2017 - 17:05 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 2 months ago. Aug 10, 2017 - 17:03 MDT
Investigating
Due to connectivity issues, users are currently not able to contact SendOutCards support via phone. Please feel free to use the site messaging system or email support@sendoutcards.com for your support needs while the issue is identified and corrected. Thank you for your patience!
Posted about 2 months ago. Aug 10, 2017 - 16:54 MDT