Data Center connectivity issues
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted 10 days ago. May 19, 2017 - 10:32 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted 10 days ago. May 19, 2017 - 10:07 MDT
Investigating
We are
Posted 10 days ago. May 19, 2017 - 10:07 MDT