Full Site Outage
Incident Report for SendOutCards
Resolved
This incident has been resolved.
Posted over 1 year ago. Aug 21, 2016 - 07:42 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 1 year ago. Aug 19, 2016 - 16:58 MDT
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Aug 19, 2016 - 16:35 MDT