Site performance problems
Incident Report for SendOutCards
Resolved
The problems have been resolved. Thank you for your patience.
Posted about 1 year ago. May 19, 2016 - 10:01 MDT
Monitoring
We have made a change that should resolve the problems. We are testing this now and monitoring to ensure the problem is completely resolved.
Posted about 1 year ago. May 19, 2016 - 09:55 MDT
Investigating
There are sporadic problems on loading some site page for some users. We are investigating the cause of the problem.
Posted about 1 year ago. May 19, 2016 - 09:21 MDT